Internet Service Disruption
Incident Report for
Georgetown ISD Systems
Resolved
This incident has been resolved.
Posted
Apr
01
,
2025
-
14:17
CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Apr
01
,
2025
-
12:19
CDT
Investigating
We are working with our internet service provider to investigate a district-wide internet service disruption.
Posted
Apr
01
,
2025
-
11:57
CDT
×
Subscribe to Incident
Subscribe to updates for
Internet Service Disruption
via . You'll receive .